Slow Requests

Incident Report for Tuple

Resolved

Response times are back to normal. We are continuing to monitor performance.
Posted Jan 07, 2026 - 22:06 UTC

Investigating

We're seeing a high P95 response times for requests to our contact endpoints.
We are investigating the issue and will update as we know more.
Posted Jan 07, 2026 - 21:51 UTC
This incident affected: Web Dashboard and API.