Email Provider Outage
Incident Report for Tuple
Resolved
This incident has been resolved.
Posted Dec 17, 2022 - 14:14 UTC
Monitoring
Our Email provider is experiencing an outage. Application emails are delayed.
Posted Dec 17, 2022 - 00:00 UTC
This incident affected: Postmark Email Sending.